Sign in to follow this  
Followers 0
iSteve-O

Custom/Contact-Specific Ring/Text Tones Not Working (macOS Sierra 10.12.2, 2016 MBP)

8 posts in this topic

Hi insanelyi friends!

 

When I setup my iOS devices, I always set the Twitter contact SMS/text tone to "none" so that I'm not constantly being dinged by those I follow.

 

I have tried to do this on my new MacBook Pro, and it does not honor the tones I have set in the contacts app, it just always uses the default tone no matter what is set in contacts.

 

Does anyone else have this issue on his/her MacBook on 10.12.2? I see on Apple support website other people have this issue (see link), but there is no fix posted. It doesn't seem to be affecting everyone or the topic would be much hotter on the support site. https://discussions.apple.com/thread/7719550?start=0&tstart=0

 

Wondering if anyone else has a fix for this, or if anyone else can at least confirm the issue exists for them as well?

 

Thanks folks! 

0

Share this post


Link to post
Share on other sites

Can you explain or show further how you set different tones in the contacts app? I wouldn't know how this would then also apply to Twitter notifications... 

 

I'll try to attempt the same then and let you know how it went.

0

Share this post


Link to post
Share on other sites
1 minute ago, TylerDurden said:

Can you explain or show further how you set different tones in the contacts app? I wouldn't know how this would then also apply to Twitter notifications... 

 

I'll try to attempt the same then and let you know how it went.

I'm talking about Twitter SMS notifications from phone number 40404. So, just like on iPhone, you go into the contacts app, edit the contact and set the ring tone and the text tone. I'm trying to set my Twitter contact text tone to "none" but iMessage on Mac ignores this setting and still dings the default SMS/iMessage tone when Twitter SMS is received. This works great on my iPhone; when I get a Twitter text it plays no sound, but the Mac seems to ignore the text tone set for the contact in the contacts app. 

 

Thanks for trying it out. Try with any contact. It doesn't have to be Twitter. It doesn't work for any contact if you look at the link I posted to the apple support topic. 

 

Thanks bud!

0

Share this post


Link to post
Share on other sites

Oh man. I'm still trying to fully understand what you are exactly doing... Firs of all I never received any Twitter notification by SMS. I only receive Twitter notifications same as all the other social media notification as a banner or pop up. Never in my iOS message app...

 

But I think if you receive Twitter notifications by SMS and they show up in your iMessages app on your macbook your best bet is to have a look into the setting of the iMessage app. 

 

 

 

0

Share this post


Link to post
Share on other sites
21 minutes ago, TylerDurden said:

Oh man. I'm still trying to fully understand what you are exactly doing... Firs of all I never received any Twitter notification by SMS. I only receive Twitter notifications same as all the other social media notification as a banner or pop up. Never in my iOS message app...

 

But I think if you receive Twitter notifications by SMS and they show up in your iMessages app on your macbook your best bet is to have a look into the setting of the iMessage app. 

 

 

 

Forget I said Twitter. That part isn't important.

 

Try changing the text tone for any contact (maybe yourself) then get a text message/iMessage from that contact (contacts app -> edit -> set text tone to "none"). MacOS ignores the custom text tone set in the contact card and uses the default tone set for the iMessage app.

 

Click the link in the original post to go to the apple support page I posted. Maybe you'll understand that better. I don't know how else to say it... Sorry, and thanks for looking into this with me. :) 

0

Share this post


Link to post
Share on other sites

Hmm nope works fine for me. No text tone at all when I set it to none on my iPhone. But iMessage isn't even popping up when I test it. Also iMessage doesn't make any sound at all :joint::huh:

0

Share this post


Link to post
Share on other sites
4 minutes ago, TylerDurden said:

Hmm nope works fine for me. No text tone at all when I set it to none on my iPhone. But iMessage isn't even popping up when I test it. Also iMessage doesn't make any sound at all :joint::huh:

No, I know it works fine on iPhone and iPad. That's all good. I can't make macOS do the same thing though. 

0

Share this post


Link to post
Share on other sites

Well at least your iMessage is doing a sound. Doesn't do that for me. I checked do not disturb and the volume level already.... Maybe iMessage is just broken in general 

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.