Boss

Cydia and Repo Errors

2.0k posts in this topic

Go into this directory:

/etc/apt/sources.list.d/

remove all files from that directory and drop these two lists in there

download.png

You'll need to unarchive the zip.

10

Share this post


Link to post
Share on other sites

In my efforts to help support this thread.... I've got another one for ya....

thumb_1314803900__0da45743.jpg

0

Share this post


Link to post
Share on other sites
post-23892-0-31677000-1312785023_thumb.p this is what happens when i try to install the repo
4

Share this post


Link to post
Share on other sites

That is correct....the proper address is repo.insanelyi.com check your spelling

1

Share this post


Link to post
Share on other sites

@Codyppc

Usually that happens if the repo is not found, either it's down or does not exist.

thumb_1312822830__screen-capture-1.png

The account has been suspended. So either that repo is gone or he's in the works of fixing it.

0

Share this post


Link to post
Share on other sites

Hey guys...

I've been reading a lot of posts in different Forums but I just can't seem to find a way to fix this.

Here's a pic of the problem:

1314803993__6f4bc9.png

I've been messing around in Terminal but with no luck.

The problem is not the "Failed to Fetch problems happens to me sometimes. Not just with insalyi repo but with some others.

The big problem is the "... section with no Package: header...." etc

0

Share this post


Link to post
Share on other sites

First have you even bothered looking at the errors above first ?

You don't have our correct repo address so it won't work. I would suggest you try and remove manually like this.

/etc/apt/sources.list.d/cydia.list

^ Open this file and remove these lines

deb http://repo.insanelyiph0ne.com ./

deb http://sinfuliphonerepo..com ./

Replace with out correct repo which is:

deb http://repo.insanelyi.com ./

Sinful iPhone is probably the cause of the no package header, If it's not I would suggest removing all extra repo's you have installed.

Now you can update in mobile terminal with:

First going root

su

password = alpine

apt-get update

2

Share this post


Link to post
Share on other sites

I'm getting these Cydia errors message when i try to update my GUI-GPG-SEC & download the OpenNotifer Premium Pack. How do I fix this?

post-11429-0-56764200-1313022693_thumb.p

post-11429-0-76028800-1313022703_thumb.p

1

Share this post


Link to post
Share on other sites

GUI-GPC-SEC error is caused by that repo's section icon is the same as ours, you can install this update to fix the issue right away. I cannot push this to the repo at this time. It will go out soon, but in the mean time the update is below.

GUI-GPC-SEC v1.5-16

download.png

2nd error you need to remove that package listed in red and then install OpenNotifier premium pack.

2

Share this post


Link to post
Share on other sites

@Sull To remove that package do I do it in Cydia or iFile & how do I go about doing that?

-1

Share this post


Link to post
Share on other sites

It's sull k

Install the deb I provided with iFIle.

for 2nd error you can solve this in Cydia. Look at the error and remove the package.

0

Share this post


Link to post
Share on other sites

when i try to install a package in any of my repos it says NOTE CANNOT_COMPLY_EX

post-24311-0-04325100-1313227176_thumb.p

0

Share this post


Link to post
Share on other sites

Never seen this before. Is this an iPhone 4 running 4.3.3 ?

0

Share this post


Link to post
Share on other sites

i have an issue with http://cydia.winterboarder.com/

when it updates there the no data error. when i try to edit it in sources it just sits there. if its a required repo, then whats wrong?

is it down?

0

Share this post


Link to post
Share on other sites

Yes it's down. That's an old repo I don't know what would be of value.

0

Share this post


Link to post
Share on other sites

What about GPG error

Release: The following signatures were invalid:

NODATA 1 NODATA 2

Its not critical but its annoying

0

Share this post


Link to post
Share on other sites

What about GPG error

Release: The following signatures were invalid:

NODATA 1 NODATA 2

Its not critical but its annoying

Probably will go away with a refresh if this is from one of the default repo's. or could be caused by other things, screenshot ?

0

Share this post


Link to post
Share on other sites

Go into this directory:

/etc/apt/sources.list.d/

remove all files from that directory and drop these two lists in there

download.png

You'll need to unarchive the zip.

I'm seeing this error also. How do you go into the directory? Thanks in advance for your help!

0

Share this post


Link to post
Share on other sites

Heyy. So whenever i open up cydia i get an error page popup and Itl either give me two sets of errors

/!\Encountered a section with no package: header

/!\You may want to run apt-get update to correct these problems

If i get this set of errors i can still use cydia but i cant refresh data.

the /!\ Is a triangle witha exlamation point in it... Just sayin.

(Or) I could get this set of errors.

(x)Could not get lock /var/lib/dpkg/lock - open (35: resource temporarily unavailible

(x)Unable to lock the administration directory (/var/lib/dpkg/.) is another process using it?

(x)Could not get lock /var/lib/dpkg/lock - open (35: resource temporarily unavailible Then i cant do anything in cydia. And respringing doesnt help. Only way to get that error away is rebooting which takes forever -__- Any suggestions? Oh and (x) Is like a circle with a x in it..post-24970-0-20027200-1313967574_thumb.p post-24970-0-86386500-1313967575_thumb.p

3

Share this post


Link to post
Share on other sites

Heyy. So whenever i open up cydia i get an error page popup and Itl either give me two sets of errors

/!\Encountered a section with no package: header

/!\You may want to run apt-get update to correct these problems

If i get this set of errors i can still use cydia but i cant refresh data.

the /!\ Is a triangle witha exlamation point in it... Just sayin.

(Or) I could get this set of errors.

(x)Could not get lock /var/lib/dpkg/lock - open (35: resource temporarily unavailible

(x)Unable to lock the administration directory (/var/lib/dpkg/.) is another process using it?

(x)Could not get lock /var/lib/dpkg/lock - open (35: resource temporarily unavailible Then i cant do anything in cydia. And respringing doesnt help. Only way to get that error away is rebooting which takes forever -__- Any suggestions? Oh and (x) Is like a circle with a x in it..

Resource locked, you have some Cydia update toggle installed I would suggest removing it.

To fix the no package header error you need MobileTerminal (NEW) from the repo

run these commands

su

password = alpine

apt-get update

If your still getting the error you will need to delete your list cache

0

Share this post


Link to post
Share on other sites

If you want to report a hack you can use the DLC Support and Report thread under Hacks & Mods forum.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.