Boss

Cydia and Repo Errors

2.0k posts in this topic

1314803337__iphone1-1.png

1314803394__iphone3.png

1314803418__iphone2.png

THE ERROS I GET WHEN I TRY TO REFRESH IT THANKS

0

Share this post


Link to post
Share on other sites

Check interent connection for 1.

Check hosts file for bombs for 2.

/etc/hosts/

0

Share this post


Link to post
Share on other sites

Check interent connection for 1.

Check hosts file for bombs for 2.

/etc/hosts/

Can you tell me how to check my host file for bombs?

0

Share this post


Link to post
Share on other sites

Can you tell me how to check my host file for bombs?

I just did.

/etc/hosts/

Make sure you don't have any of the repo url's listed in that file. I dunno might not be host issue since it can't get default repo's either. Does safari open google :)

0

Share this post


Link to post
Share on other sites

The above error was solved by clearing list cache, removing a whole lot of repo's and running apt-get update. Being the device is a iPhone 3G Cydia can take a lot of time loading, this makes it very easy to time out.

All is well :w00t:

0

Share this post


Link to post
Share on other sites

I bet nobody has seen a error like this..I'm on IOS 5 b7 trying to do some stuff with it, dont know how I really ended up with it but yah.

IMG_0002.PNG

1

Share this post


Link to post
Share on other sites

size mismatch.....

Either means your download failed and the MD5 sum does not match, a package was updated on a repo and you don't have the latest packages file, thus the MD5 does not match. Refresh Cydia and re download is the solution.

I bet nobody has seen a error like this..I'm on IOS 5 b7 trying to do some stuff with it, dont know how I really ended up with it but yah.

Yah that's a weird one, most definitely something got stuffed up somewhere....

Solution: Unknown ( A Restore fixed it though )

Possible Solution: Reinstall crucial apt packages from Cydia, etc etc.

0

Share this post


Link to post
Share on other sites

I bet nobody has seen a error like this..I'm on IOS 5 b7 trying to do some stuff with it, dont know how I really ended up with it but yah.

Thanks a lot.

Eh...here is another one......failed in buffer_write(fd)(7,ret=-1)......

0

Share this post


Link to post
Share on other sites

Thanks a lot.

Eh...here is another one......failed in buffer_write(fd)(7,ret=-1)......

Again probably just a failed download or something, refresh reload, try again.

1

Share this post


Link to post
Share on other sites

Have these Errors. How fix them? apt-get update didn't fix it.

Thank you

post-25899-0-84062400-1315108078_thumb.p

0

Share this post


Link to post
Share on other sites

apt-get update does not fix all errors, it gives you info on how to fix them. You have to read what the errors say and then go from there. In your case it says you have duplicate source hackulo.us

Go into this folder with iFile or SFTP into your iDevice:

/etc/apt/sources.list.d/cydia.list

Remove this line:

deb http://cydia.hackulo.us ./

On a side note, if you manually added hackulo repo and you also installed our hackulo repo package you would get this error, I'd go ahead and assume that's that you did here.

0

Share this post


Link to post
Share on other sites

So I'm getting this error...not a clue as to what's wrong...I've googled like three or four different times and finally decided to post something....would appreciate help.

post-699-0-32875500-1315662373_thumb.png

Just ran apt-get update and this is what I got in return...

post-699-0-96718800-1315662371_thumb.png

0

Share this post


Link to post
Share on other sites

Ok so I cleaned this up, Try checking first page...Theres a Deb you can try to manual install...And some other info...Sull's the repo master, so I'm sure he will be on to solve this if your rebooting and Deb install fails to resolve it.

0

Share this post


Link to post
Share on other sites

The deb in previous post has been pushed live since a few days ago now. That is not the issue here.

To diagnose this I'm going to need your Cydia log. Go to any package on the insanelyi repo and click 'Maintainer' it'll open up your email with the logs attached, just write in the email your the dude from the forum and I'll look it over quick. That is the first step.

extrainst is erroring out which means possibly apt-key is not installed or something is broken, just fire me that email and we can get onto the next step.

PS. you have a whole bunch of repo's with GPG errors, those repospace onces you should remove as this is just going to cause more issues.

0

Share this post


Link to post
Share on other sites

I sent the log files to you Sull, I appreciate the help in advance. I just can't figure out for the life of me what's wrong, oh and I ran syscleanpro and langpack 2.2 on this phone when I first got it, when in terminal it didn't finish running through the commands for me but it seemed to clear up my files....maybe I should restore and rejailbreak and re run everything? I'm really hoping to avoid that, even with pkgbackup, it's a pain in the ass.

0

Share this post


Link to post
Share on other sites

@Darkestbloom, ok this is the 411, look below these are the errors we're dealing with, essentially what's happening is the extrainst script is returning an error exit status 2 because it cannot import the gpg key included in the package. Now up until yesterday I have never seen this error before, I actually got to experience this error myself, looks like the latest AppleTV Build 8F455 cannot import gpg keys, I have worked with a member here and I cannot fix the problem, I downgraded the firmware on my personal AppleTV and do not have this issue, seems the issue is very rare unless you have an aTV on the latest 4.3 build. BUT for you my friend I have no idea why you would be getting this error at all, that said feel free to try out what I have been tinkering with on your iPhone, you can find everything we tried in this thread here The only thing I can think of at this point is something is broken in the OS, perhaps something gpg depends on, I just don't know.

gpg: renaming `/etc/apt/trusted.gpg' to `/etc/apt/trusted.gpg~' failed: Cross-device link

gpg: error writing keyring `/etc/apt/trusted.gpg': file rename error

gpg: error reading `/usr/share/keyrings/insanelyi-keyring.gpg': file rename error

gpg: import from `/usr/share/keyrings/insanelyi-keyring.gpg' failed: file rename error

Before yesterday I have never seen this error, our repoprep has been downloaded thousands and thousands of times and this is the first report of the error so I'm assuming it's pretty rare (other than this new case with the AppleTV) Probably your easiest option would be to do a restore and go from there, but that's up to you friend.

The error you have is exactly the same as the one on the latest AppleTV build, I'm going out on a limb and saying this is happening to everyone on that build, but without more users actually trying it I don't know, it happened to me on a fresh restore as well as another member here, I also found the same error on the XBMC forums where they require you to import their gpg key just like I do in the repo prep and a user there had the same error, NOW if this error was caused by the same thing on both iPhone and AppleTV I don't know. Go ahead and try some of the things in the thread I linked above, one thing I could not figure out is which package includes the gpg executables located in /usr/bin/ if we find out what package those are included we could try a reinstall on those.. I did a hunt for them, but found nothing.... well that's pretty much all I have to say about that :D

Good luck to you.

0

Share this post


Link to post
Share on other sites

@Darkestbloom, ok this is the 411, look below these are the errors we're dealing with, essentially what's happening is the extrainst script is returning an error exit status 2 because it cannot import the gpg key included in the package. Now up until yesterday I have never seen this error before, I actually got to experience this error myself, looks like the latest AppleTV Build 8F455 cannot import gpg keys, I have worked with a member here and I cannot fix the problem, I downgraded the firmware on my personal AppleTV and do not have this issue, seems the issue is very rare unless you have an aTV on the latest 4.3 build. BUT for you my friend I have no idea why you would be getting this error at all, that said feel free to try out what I have been tinkering with on your iPhone, you can find everything we tried in this thread here The only thing I can think of at this point is something is broken in the OS, perhaps something gpg depends on, I just don't know.

gpg: renaming `/etc/apt/trusted.gpg' to `/etc/apt/trusted.gpg~' failed: Cross-device link

gpg: error writing keyring `/etc/apt/trusted.gpg': file rename error

gpg: error reading `/usr/share/keyrings/insanelyi-keyring.gpg': file rename error

gpg: import from `/usr/share/keyrings/insanelyi-keyring.gpg' failed: file rename error

Before yesterday I have never seen this error, our repoprep has been downloaded thousands and thousands of times and this is the first report of the error so I'm assuming it's pretty rare (other than this new case with the AppleTV) Probably your easiest option would be to do a restore and go from there, but that's up to you friend.

The error you have is exactly the same as the one on the latest AppleTV build, I'm going out on a limb and saying this is happening to everyone on that build, but without more users actually trying it I don't know, it happened to me on a fresh restore as well as another member here, I also found the same error on the XBMC forums where they require you to import their gpg key just like I do in the repo prep and a user there had the same error, NOW if this error was caused by the same thing on both iPhone and AppleTV I don't know. Go ahead and try some of the things in the thread I linked above, one thing I could not figure out is which package includes the gpg executables located in /usr/bin/ if we find out what package those are included we could try a reinstall on those.. I did a hunt for them, but found nothing.... well that's pretty much all I have to say about that :D

Good luck to you.

So looks like I'm just going to have to go with a restore. Well this sucks. Oh well....thanks Sull, I appreciate all the help.

Edit:

So did a restore, still no dice. It's fucking weird.

Second Edit:

Did a clean restore. No backup. No pkgbackup. Added the repo first and installed the icon pack. No problem at all. I'm thinking what's happening is I had originally had a GP JB then updated to 4.3.3 and did a redsn0w jailbreak then moved to jbme 3.0 and used pkgbackup and restored from that pkgbackup restore, I think i'm pulling a jbme 3.0 file and it's causing problems so I'm just doing it from scratch. Thanks guys.

0

Share this post


Link to post
Share on other sites

1316394703__img_0617.png

This message keeps coming when I try to update… I'm stuck… anyone to help please ?

0

Share this post


Link to post
Share on other sites

I created this thread insight of helping users learn about what different Cydia errors that exist and how to fix them. Please if Cydia is shooting errors you can post a screenshot here, this thread is not for reporting packages that don't work or don't work as advertised.

I've cleaned this thread a little bit, but for now on lets keep it on track with just Cydia errors. If you have any issues with a package you think is not working correctly feel free to make a new thread under the appropriate forum category and the issue can be discussed there.

Thanks all

0

Share this post


Link to post
Share on other sites

That's what I want to see, if there is a depend that can't be solved you can see it on that screen in Cydia, snap a screenshot and paste here.

EDIT:

I actually know your issue already looking at the control files, seems it's quite out of date, I wil need to take a look and see if there is a newer version available.

Oh hrmm k well i am still going to attach my screenshot just so i know what to do if i ever need to ask for help again :-)post-19553-0-65845800-1317323576_thumb.p

iIt worked !!!

Edited by cinn
0

Share this post


Link to post
Share on other sites

Ya it's saying that the package requires iOS 4.2.1 or below.

Both packages are out of date I will update 1 of them later and remove the other.

0

Share this post


Link to post
Share on other sites

Hi There,

I just tried to install a Theme called "A Pink UI Plus Stuff]" out of the insanelyi repo and it failed. I have attached a screenshot from the failed installation attempt. Any idea how to get this working ? Pink is my favorite color so I generally look at and/or try any new Pink theme (I didn't see a screenshot attached to this theme which is pretty unusual - most of the time the insanelyi packages DO have a screenshot).

Thanks so much!

-cinn

post-19553-0-03636600-1318121382_thumb.j

0

Share this post


Link to post
Share on other sites

Hi There,

I just tried to install a Theme called "A Pink UI Plus Stuff]" out of the insanelyi repo and it failed. I have attached a screenshot from the failed installation attempt. Any idea how to get this working ? Pink is my favorite color so I generally look at and/or try any new Pink theme (I didn't see a screenshot attached to this theme which is pretty unusual - most of the time the insanelyi packages DO have a screenshot).

Thanks so much!

-cinn

post-19553-0-03636600-1318121382_thumb.j

Looks like corrupt deb. An update will be pushed later tonight. 1.1-1

0

Share this post


Link to post
Share on other sites

I got this message trying to install iBooks Fix.

post-29072-0-05211800-1318768043_thumb.p

Any ideas?

Regards,

ViXen

0

Share this post


Link to post
Share on other sites

I got this message trying to install iBooks Fix.

Any ideas?

Regards,

ViXen

iBooks fix is only for older firmware. not for 4.3 +

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.